« Up

continuations 8.7.0 Lint error

(2019-04-07 12:48:26 UTC)

Context

# Installed packages for system:
base-bigarray   base  Bigarray library distributed with the OCaml compiler
base-num        base  Num library distributed with the OCaml compiler
base-threads    base  Threads library distributed with the OCaml compiler
base-unix       base  Unix library distributed with the OCaml compiler
camlp5          7.06  Preprocessor-pretty-printer of OCaml
coq            8.5.3  Formal proof management system.
num                0  The Num library for arbitrary-precision integer and ration
# opam file:
opam-version: "2.0"
maintainer: "Hugo.Herbelin@inria.fr"
homepage: "https://github.com/coq-contribs/continuations"
license: "Unknown"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/Continuations"]
depends: [
  "ocaml"
  "coq" {>= "8.7" & < "8.8~"}
]
tags: [ "keyword: exceptions" "keyword: monads" "keyword: continuations" "keyword: cps" "category: Computer Science/Semantics and Compilation/Semantics" "category: Miscellaneous/Extracted Programs/Combinatorics" ]
authors: [ "Jean-François Monin" ]
bug-reports: "https://github.com/coq-contribs/continuations/issues"
dev-repo: "git+https://github.com/coq-contribs/continuations.git"
synopsis: "A toolkit to reason with programs raising exceptions"
description: """
We show a way of developing correct functionnal programs
raising exceptions. This is made possible using a Continuation
Passing Style translation, see the contribution "exceptions" from
P. Casteran at Bordeaux. Things are made easier and more modular using
some general definitions."""
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/continuations/archive/v8.7.0.tar.gz"
  checksum: "md5=1a6170334b8f2b0dbd73386952cb2d83"
}

Lint

Command
ruby lint.rb released opam-coq-archive/released/packages/coq-continuations/coq-continuations.8.7.0
Return code
256
Output
lint.rb:11:in `read': No such file or directory @ rb_sysopen - opam-coq-archive/released/packages/coq-continuations/coq-continuations.8.7.0/descr (Errno::ENOENT)
	from lint.rb:11:in `lint'
	from lint.rb:52:in `<main>'

Dry install

Dry install with the current Coq version:

Command
true
Return code
0

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
true
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none