« Up

fcsl-pcm 1.0.0 Lint error

(2019-04-07 12:48:26 UTC)

Context

# Installed packages for system:
base-bigarray   base  Bigarray library distributed with the OCaml compiler
base-num        base  Num library distributed with the OCaml compiler
base-threads    base  Threads library distributed with the OCaml compiler
base-unix       base  Unix library distributed with the OCaml compiler
camlp5          7.06  Preprocessor-pretty-printer of OCaml
coq            8.5.3  Formal proof management system.
num                0  The Num library for arbitrary-precision integer and ration
# opam file:
opam-version: "2.0"
name: "coq-fcsl-pcm"
version: "1.0.0"
maintainer: "FCSL <fcsl@software.imdea.org>"
homepage: "http://software.imdea.org/fcsl/"
bug-reports: "https://github.com/imdea-software/fcsl-pcm/issues"
dev-repo: "git+https://github.com/imdea-software/fcsl-pcm.git"
license: "Apache 2.0"
build: [ make "-j%{jobs}%" ]
install: [ make "install" ]
remove: [ "sh" "-c" "rm -rf '%{lib}%/coq/user-contrib/fcsl'" ]
depends: [
  "ocaml"
  "coq" {>= "8.7" & < "8.10~"}
  "coq-mathcomp-ssreflect" {>= "1.6.2" & <= "1.7.0"}
]
tags: [
  "keyword:separation logic"
  "keyword:partial commutative monoid"
]
authors: [
  "Aleksandar Nanevski"
]
synopsis: "Partial Commutative Monoids"
description: """
The PCM library provides a formalisation of Partial Commutative Monoids (PCMs),
a common algebraic structure used in separation logic for verification of
pointer-manipulating sequential and concurrent programs.
The library provides lemmas for mechanised and automated reasoning about PCMs
in the abstract, but also supports concrete common PCM instances, such as heaps,
histories and mutexes.
This library relies on extensionality axioms: propositional and
functional extentionality."""
url {
  src: "https://github.com/imdea-software/fcsl-pcm/archive/v1.0.0.tar.gz"
  checksum: "md5=8ea647b98ab222ae18c329bc75a86827"
}

Lint

Command
ruby lint.rb released opam-coq-archive/released/packages/coq-fcsl-pcm/coq-fcsl-pcm.1.0.0
Return code
256
Output
lint.rb:11:in `read': No such file or directory @ rb_sysopen - opam-coq-archive/released/packages/coq-fcsl-pcm/coq-fcsl-pcm.1.0.0/descr (Errno::ENOENT)
	from lint.rb:11:in `lint'
	from lint.rb:52:in `<main>'

Dry install

Dry install with the current Coq version:

Command
true
Return code
0

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
true
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none