« Up

plouffe 1.0.0 Lint error

(2019-04-07 12:48:26 UTC)

Context

# Installed packages for system:
base-bigarray   base  Bigarray library distributed with the OCaml compiler
base-num        base  Num library distributed with the OCaml compiler
base-threads    base  Threads library distributed with the OCaml compiler
base-unix       base  Unix library distributed with the OCaml compiler
camlp5          7.06  Preprocessor-pretty-printer of OCaml
coq            8.5.3  Formal proof management system.
num                0  The Num library for arbitrary-precision integer and ration
# opam file:
opam-version: "2.0"
maintainer: "Laurent.Thery@inria.fr"
homepage: "https://github.com/thery/Plouffe"
bug-reports: "https://github.com/thery/Plouffe/issues"
license: "MIT"
build: [
  ["./configure.sh"]
  [make "-j%{jobs}%"]
  [make "install"]
]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/Plouffe"]
depends: [
  "ocaml"
  "coq" {>= "8.4pl4"}
  "coq-ssreflect"
  "coq-coquelicot" {= "2.0.1"}
]
synopsis: "A Coq formalization of Plouffe formula"
authors: "Laurent Thery"
flags: light-uninstall
url {
  src: "https://github.com/thery/Plouffe/archive/v1.0.0.tar.gz"
  checksum: "md5=b877d0f05c0264b4684664d6cc090829"
}

Lint

Command
ruby lint.rb released opam-coq-archive/released/packages/coq-plouffe/coq-plouffe.1.0.0
Return code
256
Output
lint.rb:11:in `read': No such file or directory @ rb_sysopen - opam-coq-archive/released/packages/coq-plouffe/coq-plouffe.1.0.0/descr (Errno::ENOENT)
	from lint.rb:11:in `lint'
	from lint.rb:52:in `<main>'

Dry install

Dry install with the current Coq version:

Command
true
Return code
0

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
true
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none