« Up

miniml 8.5.0 Lint error

(2019-04-07 14:40:39 UTC)

Context

# Installed packages for system:
base-bigarray   base  Bigarray library distributed with the OCaml compiler
base-num        base  Num library distributed with the OCaml compiler
base-threads    base  Threads library distributed with the OCaml compiler
base-unix       base  Unix library distributed with the OCaml compiler
camlp5          7.06  Preprocessor-pretty-printer of OCaml
conf-m4            1  Virtual package relying on m4
coq            8.6.1  Formal proof management system.
num                0  The Num library for arbitrary-precision integer and ration
ocamlfind      1.8.0  A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "matej.kosik@inria.fr"
homepage: "https://github.com/coq-contribs/miniml"
license: "LGPL 2"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/MiniML"]
depends: [
  "ocaml"
  "coq" {>= "8.5" & < "8.6~"}
]
tags: [ "keyword:functional programming" "keyword:categorical abstract machine" "keyword:compilation" "keyword:natural semantics" "category:Computer Science/Semantics and Compilation/Compilation" ]
authors: [ "Samuel Boutin <>" ]
bug-reports: "https://github.com/coq-contribs/miniml/issues"
dev-repo: "git+https://github.com/coq-contribs/miniml.git"
synopsis: "Correctness of the compilation of Mini-ML into the Categorical Abstract Machine"
description: """
A formalisation of Mini-ML and of the Categorical
Abstract Machine (C.A.M) in natural semantics. It also contains the
definition of the translation from Mini-ML to the CAM and the proof
that this translation is correct"""
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/miniml/archive/v8.5.0.tar.gz"
  checksum: "md5=ad1936dc8998fe3bba52b15abd7deea4"
}

Lint

Command
ruby lint.rb released opam-coq-archive/released/packages/coq-miniml/coq-miniml.8.5.0
Return code
256
Output
lint.rb:11:in `read': No such file or directory @ rb_sysopen - opam-coq-archive/released/packages/coq-miniml/coq-miniml.8.5.0/descr (Errno::ENOENT)
	from lint.rb:11:in `lint'
	from lint.rb:52:in `<main>'

Dry install

Dry install with the current Coq version:

Command
true
Return code
0

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
true
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none