« Up

weak-up-to 8.8.0 Lint error

(2019-04-07 14:40:39 UTC)

Context

# Installed packages for system:
base-bigarray   base  Bigarray library distributed with the OCaml compiler
base-num        base  Num library distributed with the OCaml compiler
base-threads    base  Threads library distributed with the OCaml compiler
base-unix       base  Unix library distributed with the OCaml compiler
camlp5          7.06  Preprocessor-pretty-printer of OCaml
conf-m4            1  Virtual package relying on m4
coq            8.6.1  Formal proof management system.
num                0  The Num library for arbitrary-precision integer and ration
ocamlfind      1.8.0  A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "Hugo.Herbelin@inria.fr"
homepage: "https://github.com/coq-contribs/weak-up-to"
license: "GPL"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/WeakUpTo"]
depends: [
  "ocaml"
  "coq" {>= "8.8" & < "8.9~"}
]
tags: [ "keyword: weak bisimilarity" "keyword: weak bisimulation" "keyword: up-to techniques" "keyword: termination" "keyword: commutation" "keyword: Newman's Lemma." "category: Computer Science/Concurrent Systems and Protocols/Theory of concurrent systems" "date: 2005-02-22" ]
authors: [ "Damien Pous <damien.pous at ens-lyon.fr> [http://perso.ens-lyon.fr/damien.pous/]" ]
bug-reports: "https://github.com/coq-contribs/weak-up-to/issues"
dev-repo: "git+https://github.com/coq-contribs/weak-up-to.git"
synopsis: "New Up-to Techniques for Weak Bisimulation"
description: """
http://perso.ens-lyon.fr/damien.pous/upto/
This contribution is the formalisation of a paper that appeared in
Proc. of ICALP 2005: "Up-to Techniques for Weak Bisimulation".
First we define a framework for defining up-to techniques for weak
bisimulation in a modular way. Then we prove the correctness of some
new up-to techniques, based on termination guarantees. Notably, a
generalisation of Newman's Lemma to commutation results is
established."""
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/weak-up-to/archive/v8.8.0.tar.gz"
  checksum: "md5=5e43d24251faf4a5603d6c07e6ab540c"
}

Lint

Command
ruby lint.rb released opam-coq-archive/released/packages/coq-weak-up-to/coq-weak-up-to.8.8.0
Return code
256
Output
lint.rb:11:in `read': No such file or directory @ rb_sysopen - opam-coq-archive/released/packages/coq-weak-up-to/coq-weak-up-to.8.8.0/descr (Errno::ENOENT)
	from lint.rb:11:in `lint'
	from lint.rb:52:in `<main>'

Dry install

Dry install with the current Coq version:

Command
true
Return code
0

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
true
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none