« Up

legacy-ring 8.6.0 Not compatible

(2019-07-07 02:48:55 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
coq                 8.5.3             Formal proof management system.
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
# opam file:
opam-version: "2.0"
maintainer: "Hugo.Herbelin@inria.fr"
homepage: "https://github.com/coq-contribs/legacy-ring"
license: "Unknown"
build: [make "-j%{jobs}%"]
install: [make "install"]
depends: [
  "ocaml"
  "coq" {>= "8.6" & < "8.7~"}
]
tags: [ "date: 1998-5" ]
authors: [ "Patrick Loiseleur" ]
bug-reports: "https://github.com/coq-contribs/legacy-ring/issues"
dev-repo: "git+https://github.com/coq-contribs/legacy-ring.git"
synopsis: "The former implementation of the ring tactic"
description: """
Tactics to decide equality and simplify polynomial
expressions over an arbitrary commutative ring. This generalizes a
previous tactics by Samuel Boutin."""
url {
  src: "https://github.com/coq-contribs/legacy-ring/archive/v8.6.0.tar.gz"
  checksum: "md5=6c54ffd5bf1e4f816c5d404ca87d079b"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-legacy-ring.8.6.0 coq.8.5.3
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.5.3).
The following dependencies couldn't be met:
  - coq-legacy-ring -> coq >= 8.6
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-legacy-ring.8.6.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none