« Up

ltl 8.6.0 Not compatible

(2019-10-11 12:22:10 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
coq                 8.5.3       Formal proof management system.
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
# opam file:
opam-version: "2.0"
maintainer: "Hugo.Herbelin@inria.fr"
homepage: "https://github.com/coq-contribs/ltl"
license: "Unknown"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/LTL"]
depends: [
  "ocaml"
  "coq" {>= "8.6" & < "8.7~"}
]
tags: [ "keyword: temporal logic" "keyword: infinite transition systems" "keyword: co-induction" "category: Mathematics/Logic/Modal logic" "date: 2002-07" ]
authors: [ "Solange Coupet-Grimal" ]
bug-reports: "https://github.com/coq-contribs/ltl/issues"
dev-repo: "git+https://github.com/coq-contribs/ltl.git"
synopsis: "Linear Temporal Logic"
description: """
This contribution contains a shallow embedding of Linear
Temporal Logic (LTL) based on a co-inductive representation of program
executions. Temporal operators are implemented as inductive
(respectively co-inductive) types when they are least (respectively
greatest) fixpoints. Several general lemmas,
that correspond to LTL rules, are proved."""
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/ltl/archive/v8.6.0.tar.gz"
  checksum: "md5=05ca4e6bc7bd9de73c904ba2f6fae519"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-ltl.8.6.0 coq.8.5.3
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.5.3).
The following dependencies couldn't be met:
  - coq-ltl -> coq >= 8.6
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-ltl.8.6.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none