« Up

mathcomp-real-closed 1.0.1 Not compatible

(2019-10-11 12:22:10 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
coq                 8.5.3       Formal proof management system.
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
# opam file:
opam-version: "2.0"
name: "coq-mathcomp-real-closed"
version: "1.0.1"
maintainer: "Mathematical Components <mathcomp-dev@sympa.inria.fr>"
homepage: "http://math-comp.github.io/math-comp/"
bug-reports: "Mathematical Components <mathcomp-dev@sympa.inria.fr>"
dev-repo: "git+https://github.com/math-comp/real-closed.git"
license: "CeCILL-B"
build: [ make "-j" "%{jobs}%" ]
install: [ make "install" ]
remove: [ "sh" "-c" "rm -rf '%{lib}%/coq/user-contrib/mathcomp/real_closed'" ]
depends: [
  "ocaml"
  "coq-mathcomp-field" {= "1.7.0"}
]
tags: [ "keyword:real closed field" "keyword:small scale reflection" "keyword:mathematical components" ]
authors: [ "Cyril Cohen <>" "Assia Mahboubi <>" ]
synopsis: "Mathematical Components Library on real closed fields"
url {
  src: "https://github.com/math-comp/real-closed/archive/1.0.1.tar.gz"
  checksum: "md5=0e6cb43fccb7cfeb82f7700270d5a147"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-mathcomp-real-closed.1.0.1 coq.8.5.3
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.5.3).
The following dependencies couldn't be met:
  - coq-mathcomp-real-closed -> coq-mathcomp-field = 1.7.0 -> coq-mathcomp-solvable = 1.7.0 -> coq-mathcomp-algebra = 1.7.0 -> coq-mathcomp-fingroup = 1.7.0 -> coq-mathcomp-ssreflect = 1.7.0 -> coq >= 8.6
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-mathcomp-real-closed.1.0.1
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none