« Up

opam-website 1.0.0 Not compatible

(2019-07-16 12:41:17 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
coq                 8.5.3             Formal proof management system.
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
# opam file:
opam-version: "2.0"
maintainer: "dev@clarus.me"
homepage: "https://github.com/clarus/coq-opam-website"
dev-repo: "git+https://github.com/clarus/coq-opam-website.git"
bug-reports: "https://github.com/clarus/coq-opam-website/issues"
authors: ["Guillaume Claret"]
license: "MIT"
build: [
  ["./configure.sh"]
  [make "-j%{jobs}%"]
  ["sh" "-c" "cd extraction && make"]
]
depends: [
  "ocaml"
  "coq" {>= "8.4pl4"}
  "coq-io" {>= "3.0.0"}
  "coq-io-exception" {>= "1.0.0"}
  "coq-io-system" {>= "2.2.0" & < "2.3.0"}
  "coq-list-string" {>= "2.1.0"}
]
synopsis: "Generation of a Coq website for OPAM: http://coq.io/opam/ "
url {
  src: "https://github.com/clarus/coq-opam-website/archive/1.0.0.tar.gz"
  checksum: "md5=8e5485ebaf730a661cf7cd35976c407c"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-opam-website.1.0.0 coq.8.5.3
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.5.3).
The following dependencies couldn't be met:
  - coq-opam-website -> coq-io-exception -> coq < 8.5~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-opam-website.1.0.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none