« Up

pigeonhole-principle 1.0.3 Not compatible

(2019-06-15 04:53:50 UTC)

Context

# Packages matching: installed
# Name        # Installed       # Synopsis
base-bigarray base
base-num      base              Num library distributed with the OCaml compiler
base-threads  base
base-unix     base
camlp5        7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
coq           8.5.3             Formal proof management system.
num           0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml         4.05.0            The OCaml compiler (virtual package)
ocaml-config  1                 OCaml Switch Configuration
ocaml-system  4.05.0            The OCaml compiler (system version, from outside of opam)
# opam file:
opam-version: "2.0"
maintainer: "llee454@gmail.com"
homepage: "https://github.com/llee454/pigeons"
dev-repo: "git+https://github.com/llee454/pigeons.git"
bug-reports: "https://github.com/llee454/pigeons/issues"
authors: ["Larry D. Lee Jr."]
license: "LGPLv3"
build: [
  [make "-j%{jobs}%"]
]
install: [
  [make "install"]
]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/pigeonhole_principle"]
depends: [
  "ocaml"
  "coq" {>= "8.8"}
]
tags: [
  "keyword:pigeon-hole principle"
  "keyword:mathematics"
  "category:Math/Combinatorics and Graph Theory"
  "date:2018-08-25"
  "logpath:pigeonhole-principle"
]
synopsis: "This library provides a stand-alone proof of the Pigeonhole"
description: """
principle. The Pigeonhole principle is a fundamental theorem that
is used widely in Computer Science and Combinatorics, it asserts
that if you put n things into m containers, and n > m, then at
least one of the containers contains more than one thing.
For more information about this proof, Please read its Readme file,
which can be found here: 
https://github.com/llee454/pigeons"""
flags: light-uninstall
url {
  src: "https://github.com/llee454/pigeons/archive/v1.0.3.tar.gz"
  checksum: "md5=f7ca3241a228f53de453ae1662446688"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-pigeonhole-principle.1.0.3 coq.8.5.3
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.5.3).
The following dependencies couldn't be met:
  - coq-pigeonhole-principle -> coq >= 8.8
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-pigeonhole-principle.1.0.3
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none