« Up

qcert 1.0.9 Not compatible

(2019-07-16 12:41:17 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
coq                 8.5.3             Formal proof management system.
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
# opam file:
opam-version: "2.0"
maintainer: "jeromesimeon@me.com"
homepage: "https://querycert.github.io"
dev-repo: "git+https://github.com/querycert/qcert"
bug-reports: "https://github.com/querycert/qcert/issues"
authors: [ "Josh Auerbach" "Martin Hirzel" "Louis Mandel" "Avi Shinnar" "Jerome Simeon" ]
license: "Apache-2.0"
build: [
  [make "-j%{jobs}%" "qcert-coq"]
]
install: [
  [make "install-coq"]
]
depends: [
  "ocaml"
  "coq" {>= "8.7.2" & < "8.8"}
  "coq-flocq" {>= "2.6.0"}
  "coq-jsast" {>= "1.0.7"}
]
synopsis: "Verified compiler for data-centric languages"
url {
  src: "https://github.com/querycert/qcert/archive/v1.0.9.tar.gz"
  checksum: "md5=f04c8466cc2310baec0bc277fced0911"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-qcert.1.0.9 coq.8.5.3
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.5.3).
The following dependencies couldn't be met:
  - coq-qcert -> coq >= 8.7.2
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-qcert.1.0.9
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none