« Up

amm11262 8.5.0 Not compatible

(2019-10-16 01:51:09 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-m4             1           Virtual package relying on m4
coq                 8.6.1       Formal proof management system.
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "matej.kosik@inria.fr"
homepage: "https://github.com/coq-contribs/amm11262"
license: "LGPL"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/AMM11262"]
depends: [
  "ocaml"
  "coq" {>= "8.5" & < "8.6~"}
]
tags: [ "keyword:american mathematical monthly problem 11262" "date:2007-04" ]
authors: [ "Tonny Hurkens (paper proof) <hurkens@sci.kun.nl>" "Milad Niqui (Coq files) <milad@cs.ru.nl>" ]
bug-reports: "https://github.com/coq-contribs/amm11262/issues"
dev-repo: "git+https://github.com/coq-contribs/amm11262.git"
synopsis: "Problem 11262 of The American Mathematical Monthly"
description: """
Formalisation of Tonny Hurkens' proof of the problem
11262 of The American Mathematical Monthly 113(10), Dec. 2006
(see the README files)"""
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/amm11262/archive/v8.5.0.tar.gz"
  checksum: "md5=8844a7a417070386a907b97cf71a413d"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-amm11262.8.5.0 coq.8.6.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.6.1).
The following dependencies couldn't be met:
  - coq-amm11262 -> coq < 8.6~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-amm11262.8.5.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none