« Up

bertrand 8.7.0 Not compatible

(2019-07-15 10:52:38 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
conf-m4             1                 Virtual package relying on m4
coq                 8.6.1             Formal proof management system.
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
ocamlfind           1.8.0             A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "Hugo.Herbelin@inria.fr"
homepage: "https://github.com/coq-community/bertrand"
license: "LGPL 2.1"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/Bertrand"]
depends: [
  "ocaml"
  "coq" {>= "8.7" & < "8.8~"}
]
tags: [ "keyword: Knuth's algorithm" "keyword: prime numbers" "keyword: Bertrand's postulate" "category: Mathematics/Arithmetic and Number Theory/Number theory" "category: Computer Science/Decision Procedures and Certified Algorithms/Correctness proofs based on external tools" "category: Miscellaneous/Extracted Programs/Arithmetic" "date: 2002" ]
authors: [ "Laurent Théry" ]
bug-reports: "https://github.com/coq-community/bertrand/issues"
dev-repo: "git+https://github.com/coq-community/bertrand.git"
synopsis: "Correctness of Knuth's algorithm for prime numbers"
description: """
A proof of correctness of the algorithm as described in
`The Art of Computer Programming: Fundamental Algorithms'
by Knuth, pages 147-149"""
flags: light-uninstall
url {
  src: "https://github.com/coq-community/bertrand/archive/v8.7.0.tar.gz"
  checksum: "md5=94c1f46fd9ba1f18c956f3fac62dff4a"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-bertrand.8.7.0 coq.8.6.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.6.1).
The following dependencies couldn't be met:
  - coq-bertrand -> coq >= 8.7
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-bertrand.8.7.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none