« Up

concurrency-pluto 1.0.0 Not compatible

(2019-07-15 10:52:38 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
conf-m4             1                 Virtual package relying on m4
coq                 8.6.1             Formal proof management system.
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
ocamlfind           1.8.0             A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "dev@clarus.me"
homepage: "https://github.com/coq-concurrency/pluto"
dev-repo: "git+https://github.com/coq-concurrency/pluto.git"
bug-reports: "https://github.com/coq-concurrency/pluto/issues"
authors: ["Guillaume Claret"]
license: "MIT"
build: [
  ["./configure.sh"]
  [make "-j%{jobs}%"]
  [make "-C" "extraction"]
]
depends: [
  "ocaml"
  "coq" {>= "8.4pl4"}
  "coq-error-handlers"
  "coq-function-ninjas"
  "coq-iterable"
  "coq-list-string" {>= "2.0.0"}
  "coq-moment"
  "coq-concurrency-proxy"
  "coq-concurrency-system" {< "1.1.0"}
  "base64" {= "1.0.0"}
]
tags: [
  "date:2015-01-28"
  "keyword:effects"
  "keyword:extraction"
  "keyword:webserver"
]
synopsis: "A web server written in Coq"
extra-files: [
  "coq-concurrency-pluto.install" "md5=c191e439136807d785f0d582e0b8783e"
]
url {
  src: "https://github.com/coq-concurrency/pluto/archive/1.0.0.tar.gz"
  checksum: "md5=58a8fab5208e4ed422c031e8e8ec8af1"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-concurrency-pluto.1.0.0 coq.8.6.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.6.1).
The following dependencies couldn't be met:
  - coq-concurrency-pluto -> coq-concurrency-system < 1.1.0 -> coq < 8.6 -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-concurrency-pluto.1.0.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none