« Up

dep-map 8.8.0 Not compatible

(2019-07-15 10:52:38 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
conf-m4             1                 Virtual package relying on m4
coq                 8.6.1             Formal proof management system.
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
ocamlfind           1.8.0             A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "Hugo.Herbelin@inria.fr"
homepage: "https://github.com/coq-contribs/dep-map"
license: "CeCILL-B"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/DepMap"]
depends: [
  "ocaml"
  "coq" {>= "8.8" & < "8.9~"}
]
tags: [ "keyword: Maps" "keyword: Dependent maps" "keyword: domain" "category: Computer Science/Data Types and Data Structures" ]
authors: [ "Lionel Rieg <lionel.rieg@college-de-france.fr>" ]
bug-reports: "https://github.com/coq-contribs/dep-map/issues"
dev-repo: "git+https://github.com/coq-contribs/dep-map.git"
synopsis: "Dependent Maps"
description:
  "A rudimentary library for dependent maps that contain their domain in the type."
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/dep-map/archive/v8.8.0.tar.gz"
  checksum: "md5=178b5c2b223fe9344b8cd06068cd5863"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-dep-map.8.8.0 coq.8.6.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.6.1).
The following dependencies couldn't be met:
  - coq-dep-map -> coq >= 8.8
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-dep-map.8.8.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none