« Up

mini-compiler 8.5.0 Not compatible

(2019-07-15 10:52:38 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
conf-m4             1                 Virtual package relying on m4
coq                 8.6.1             Formal proof management system.
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
ocamlfind           1.8.0             A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "matej.kosik@inria.fr"
homepage: "https://github.com/coq-contribs/mini-compiler"
license: "LGPL 2"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/MiniCompiler"]
depends: [
  "ocaml"
  "coq" {>= "8.5" & < "8.6~"}
]
tags: [ "keyword:compilation" "keyword:correctness" "keyword:arithmetic" "category:Computer Science/Semantics and Compilation/Compilation" "date:2003" ]
authors: [ "Jean-Christophe Filliâtre <>" ]
bug-reports: "https://github.com/coq-contribs/mini-compiler/issues"
dev-repo: "git+https://github.com/coq-contribs/mini-compiler.git"
synopsis: "Correctness of a tiny compiler for arithmetic expressions"
description: """
Tutorial correctness proof of a tiny compiler from
simple arithmetic expressions (constants, variables and additions) to
simple assembly-like code (one accumulator, infinitly many registers and
addition)"""
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/mini-compiler/archive/v8.5.0.tar.gz"
  checksum: "md5=27b1414ce51c9cfe014d5777e9d47b2e"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-mini-compiler.8.5.0 coq.8.6.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.6.1).
The following dependencies couldn't be met:
  - coq-mini-compiler -> coq < 8.6~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-mini-compiler.8.5.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none