« Up

ptsatr 8.5.0 Not compatible

(2019-11-11 19:08:57 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-findutils      1           Virtual package relying on findutils
conf-m4             1           Virtual package relying on m4
coq                 8.6.1       Formal proof management system.
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "matej.kosik@inria.fr"
homepage: "https://github.com/coq-contribs/ptsatr"
license: "LGPL"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/PTSATR"]
depends: [
  "ocaml"
  "coq" {>= "8.5" & < "8.6~"}
]
tags: [ "keyword:pure type systems" "keyword:judgmental equality" "keyword:chruch rosser" "keyword:confluence" "keyword:subject reduction" "keyword:pi injectivity" "category:Mathematics/Logic/Type theory" ]
authors: [ "Vincent Siles <vincent.siles@ens-lyon.org>" "Hugo Herbelin <hugo.herbelin@inria.fr>" ]
bug-reports: "https://github.com/coq-contribs/ptsatr/issues"
dev-repo: "git+https://github.com/coq-contribs/ptsatr.git"
synopsis: "PTSATR"
description: """
Formalization of the proof that PTS and PTS with judgmental equality (PTSe) are equivalent.
With this equivalence, we are able to derive all the meta-theory of PTSe, like Pi-injectivity or Subject Reduction."""
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/ptsatr/archive/v8.5.0.tar.gz"
  checksum: "md5=4ba0c590baf4df955e3440ca456440ce"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-ptsatr.8.5.0 coq.8.6.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.6.1).
The following dependencies couldn't be met:
  - coq-ptsatr -> coq < 8.6~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-ptsatr.8.5.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none