« Up

hammer 1.0.3 Not compatible

(2019-11-14 05:58:04 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-findutils      1           Virtual package relying on findutils
conf-m4             1           Virtual package relying on m4
coq                 8.7.2       Formal proof management system.
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "Julien Narboux <julien@narboux.fr>"
homepage: "http://cl-informatik.uibk.ac.at/cek/coqhammer/"
bug-reports: "mailto://lukaszcz@mimuw.edu.pl"
authors: ["Ł. Czajka"
 	  "Cezary Kaliszyk"]
license: "LGPL 2.1"
build: [
  ["sed" "-i" "s|usr\\/local|%{prefix}%|g" "_CoqProject"]
  ["coq_makefile" "-f" "_CoqProject" "-o" "Makefile"]
  [make]
]
install: [
  [make "install"]
]
remove: [
	["rm" "-R" "%{lib}%/coq/user-contrib/Hammer"]
	["rm" "%{prefix}%/bin/predict"]
]
depends: [
  "ocaml"
  "conf-g++" {build}
  "coq" {(>= "8.6" & < "8.7~")}
]
tags: [ "keyword:automation"
	"category:Misc/Coq Extensions"
	"date:2017-09-30"  ]
synopsis: "Automation for Dependent Type Theory"
flags: light-uninstall
url {
  src:
    "http://cl-informatik.uibk.ac.at/cek/coqhammer/coqhammer-1.0.3-coq8.6.tar.gz"
  checksum: "md5=4d0fb044c9ddecac60b6aea7310a2379"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-hammer.1.0.3 coq.8.7.2
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.7.2).
The following dependencies couldn't be met:
  - coq-hammer -> coq < 8.7~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-hammer.1.0.3
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none