« Up

hammer 1.0.8+8.7 13 s

(2019-11-14 05:58:04 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-findutils      1           Virtual package relying on findutils
conf-m4             1           Virtual package relying on m4
coq                 8.7.2       Formal proof management system.
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "palmskog@gmail.com"
homepage: "https://github.com/lukaszcz/coqhammer"
dev-repo: "git+https://github.com/lukaszcz/coqhammer.git"
bug-reports: "https://github.com/lukaszcz/coqhammer/issues"
license: "LGPL 2.1"
build: [ make ]
install: [ make "install" ]
remove: [
  ["sh" "-c" "rm -rf '%{lib}%/coq/user-contrib/Hammer'"]
  ["sh" "-c" "rm -f '%{bin}%/predict' '%{bin}%/htimeout'"]
]
depends: [
  "ocaml"
  "conf-g++" {build}
  "coq" {>= "8.7" & < "8.8~"}
]
tags: [ "keyword:automation"
	"category:Misc/Coq Extensions"
	"date:2018-04-09" ]
authors: [
  "Lukasz Czajka <lukaszcz@mimuw.edu.pl>"
  "Cezary Kaliszyk <cezary.kaliszyk@uibk.ac.at>"
  "Burak Ekici <burak.ekici@uibk.ac.at>"
]
synopsis: "Automation for Dependent Type Theory"
url {
  src: "https://github.com/lukaszcz/coqhammer/archive/v1.0.8-coq8.7.tar.gz"
  checksum: "md5=01267d1ade74dd431ba15cee21c87217"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-hammer.1.0.8+8.7 coq.8.7.2
Return code
0

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
true
Return code
0

Install dependencies

Command
opam list; echo; ulimit -Sv 4000000; timeout 2h opam install -y --deps-only coq-hammer.1.0.8+8.7 coq.8.7.2
Return code
0
Duration
3 s

Install

Command
opam list; echo; ulimit -Sv 4000000; timeout 1h opam install -y -v coq-hammer.1.0.8+8.7 coq.8.7.2
Return code
0
Duration
13 s

Installation size

Total: 1 M

  • 669 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/hammer_plugin.cmxs
  • 243 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/Reconstr.vo
  • 126 K ../ocaml-base-compiler.4.05.0/bin/predict
  • 50 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/Reconstr.glob
  • 44 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/Reconstr.v
  • 25 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/Hammer.vo
  • 19 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/hammer_plugin.cmxa
  • 15 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/hammer.cmi
  • 13 K ../ocaml-base-compiler.4.05.0/bin/htimeout
  • 11 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/hammer.cmx
  • 8 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/coqterms.cmi
  • 6 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/coqterms.cmx
  • 5 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/coq_transl.cmx
  • 4 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/features.cmx
  • 3 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/timeout.cmi
  • 3 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/timeout.cmx
  • 3 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/provers.cmx
  • 2 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/opt.cmi
  • 2 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/tptp_out.cmx
  • 2 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/hhlib.cmi
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/coq_transl_opts.cmi
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/opt.cmx
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/features.cmi
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/provers.cmi
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/coq_transl.cmi
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/hhlib.cmx
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/coq_convert.cmx
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/hh_term.cmi
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/parallel.cmi
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/msg.cmi
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/tptp_out.cmi
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/msg.cmx
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/coq_convert.cmi
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/coq_transl_opts.cmx
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/hh_term.cmx
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/parallel.cmx
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/hammer_errors.cmi
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/hammer_errors.cmx
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/Hammer.glob
  • 1 K ../ocaml-base-compiler.4.05.0/lib/coq/user-contrib/Hammer/Hammer.v

Uninstall

Command
opam remove -y coq-hammer.1.0.8+8.7
Return code
0
Missing removes
none
Wrong removes
none