« Up

paramcoq 1.1.1+coq8.9 Not compatible

(2019-11-14 05:58:04 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-findutils      1           Virtual package relying on findutils
conf-m4             1           Virtual package relying on m4
coq                 8.7.2       Formal proof management system.
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
synopsis: "Paramcoq"
name: "coq-paramcoq"
version: "1.1.1+coq8.9"
maintainer: "Pierre Roux <pierre.roux@onera.fr>"
homepage: "https://github.com/coq-community/paramcoq"
dev-repo: "git+https://github.com/coq-community/paramcoq.git"
bug-reports: "https://github.com/coq-community/paramcoq/issues"
license: "MIT"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/Param"]
depends: [
  "ocaml"
  "coq" {>= "8.9" & < "8.10~"}
]
tags: [
  "keyword:paramcoq"
  "keyword:parametricity"
  "keyword:ocaml module"
  "category:paramcoq"
  "category:Miscellaneous/Coq Extensions"
  "logpath:Param"
]
authors: [
  "Chantal Keller (Inria, École polytechnique)"
  "Marc Lasson (ÉNS de Lyon)"
  "Abhishek Anand"
  "Pierre Roux"
  "Emilio Jesús Gallego Arias"
  "Cyril Cohen"
  "Matthieu Sozeau"
]
flags: light-uninstall
url {
  src:
    "https://github.com/coq-community/paramcoq/archive/v1.1.1+coq8.9.tar.gz"
  checksum: "md5=e0ca9436a81fd47e676541254d28e8bb"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-paramcoq.1.1.1+coq8.9 coq.8.7.2
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.7.2).
The following dependencies couldn't be met:
  - coq-paramcoq -> coq >= 8.9
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-paramcoq.1.1.1+coq8.9
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none