« Up

miniml 8.7.0 Not compatible

(2019-10-05 07:30:19 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-m4             1           Virtual package relying on m4
coq                 8.8.1       Formal proof management system.
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "Hugo.Herbelin@inria.fr"
homepage: "https://github.com/coq-contribs/miniml"
license: "LGPL 2.1"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/MiniML"]
depends: [
  "ocaml"
  "coq" {>= "8.7" & < "8.8~"}
]
tags: [ "keyword: functional programming" "keyword: Categorical Abstract Machine" "keyword: compilation" "keyword: natural semantics" "category: Computer Science/Semantics and Compilation/Compilation" ]
authors: [ "Samuel Boutin" ]
bug-reports: "https://github.com/coq-contribs/miniml/issues"
dev-repo: "git+https://github.com/coq-contribs/miniml.git"
synopsis: "Correctness of the compilation of Mini-ML into the Categorical Abstract Machine"
description: """
A formalisation of Mini-ML and of the Categorical
Abstract Machine (C.A.M) in natural semantics. It also contains the
definition of the translation from Mini-ML to the CAM and the proof
that this translation is correct"""
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/miniml/archive/v8.7.0.tar.gz"
  checksum: "md5=d9d24a2a772e2dfe8830b7cc3e85be57"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-miniml.8.7.0 coq.8.8.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.8.1).
The following dependencies couldn't be met:
  - coq-miniml -> coq < 8.8~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-miniml.8.7.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none