« Up

bertrand 8.5.0 Not compatible

(2019-10-28 06:37:34 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-m4             1           Virtual package relying on m4
coq                 8.8.2       Formal proof management system.
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "matej.kosik@inria.fr"
homepage: "https://github.com/coq-contribs/bertrand"
license: "LGPL 2"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/Bertrand"]
depends: [
  "ocaml"
  "coq" {>= "8.5" & < "8.6~"}
]
tags: [ "keyword:knuth's algorithm" "keyword:prime numbers" "keyword:bertrand's postulate" "category:Mathematics/Arithmetic and Number Theory/Number theory" "category:Computer Science/Decision Procedures and Certified Algorithms/Correctness proofs based on external tools" "category:Miscellaneous/Extracted Programs/Arithmetic" "date:2002" ]
authors: [ "Laurent Théry <>" ]
bug-reports: "https://github.com/coq-contribs/bertrand/issues"
dev-repo: "git+https://github.com/coq-contribs/bertrand.git"
synopsis: "Correctness of Knuth's algorithm for prime numbers"
description: """
A proof of correctness of the algorithm as described in
`The Art of Computer Programming: Fundamental Algorithms'
by Knuth, pages 147-149"""
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/bertrand/archive/v8.5.0.tar.gz"
  checksum: "md5=d7ed1b44196c96be0b55fc4fb3967d74"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-bertrand.8.5.0 coq.8.8.2
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.8.2).
The following dependencies couldn't be met:
  - coq-bertrand -> coq < 8.6~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-bertrand.8.5.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none