« Up

gappa 1.3.3 Not compatible

(2019-10-10 18:58:50 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-m4             1           Virtual package relying on m4
coq                 8.8.2       Formal proof management system.
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "guillaume.melquiond@inria.fr"
homepage: "http://gappa.gforge.inria.fr/"
dev-repo: "git+https://scm.gforge.inria.fr/anonscm/git/gappa/coq.git"
license: "LGPL 2.1"
build: [
  ["./configure"]
  ["./remake" "-j%{jobs}%"]
]
install: ["./remake" "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/Gappa"]
depends: [
  "ocaml"
  "coq" {>= "8.4pl4" & < "8.8~" & != "8.4.6~camlp4" & != "8.5.0~camlp4" & != "8.5.2~camlp4"}
  "coq-flocq" {>= "2.5" & < "3.0~"}
]
tags: [ "keyword:floating point arithmetic" "keyword:interval arithmetic" "keyword:decision procedure" "category:Computer Science/Decision Procedures and Certified Algorithms/Decision procedures" ]
authors: [ "Guillaume Melquiond <guillaume.melquiond@inria.fr>" ]
synopsis:
  "A Coq tactic for discharging goals about floating-point arithmetic and"
description: "round-off errors using the Gappa prover."
flags: light-uninstall
url {
  src:
    "https://gforge.inria.fr/frs/download.php/file/37395/gappalib-coq-1.3.3.tar.gz"
  checksum: "md5=0a8b1513011904d6569dc98794271bb6"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-gappa.1.3.3 coq.8.8.2
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.8.2).
The following dependencies couldn't be met:
  - coq-gappa -> coq < 8.8~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-gappa.1.3.3
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none