« Up

min-imports 1.0.1 4 s

(2019-07-12 21:28:46 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
conf-m4             1                 Virtual package relying on m4
coq                 8.8.2             Formal proof management system.
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
ocamlfind           1.8.0             A library manager for OCaml
# opam file:
opam-version: "2.0"
version: "1.0.1"
maintainer: "lord@crocodile.org"
homepage: "https://github.com/vzaliva/coq-min-imports"
dev-repo: "git+https://github.com/vzaliva/coq-min-imports.git"
bug-reports: "https://github.com/vzaliva/coq-min-imports/issues"
authors: ["Vadim Zaliva"]
license: "MIT"
build: ["jbuilder" "build" "-j" jobs "@install"]
depends: [
  "ocaml"
  "coq" {>= "8.5"}
  "extlib"
  "batteries"
  "jbuilder" {build}
]
tags: [
  "category:Miscellaneous/Coq Extensions"
  "date:2018-04-22"
]
synopsis:
  "This script will try to remove unnecessary module imports from Coq"
description: """
sources. It examines modules listed in "Require Import" statements one
by one and tries to recompile to see if their removal would cause
compilation errors."""
url {
  src: "https://github.com/vzaliva/coq-min-imports/archive/v1.0.1.tar.gz"
  checksum: "md5=3ffca724f7e8752ce4f1909b360914ab"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-min-imports.1.0.1 coq.8.8.2
Return code
0

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
true
Return code
0

Install dependencies

Command
opam list; echo; ulimit -Sv 4000000; timeout 60m opam install -y --deps-only coq-min-imports.1.0.1
Return code
0
Duration
1 m 0 s

Install

Command
opam list; echo; ulimit -Sv 4000000; timeout 60m opam install -j1 -y -v coq-min-imports.1.0.1
Return code
0
Duration
4 s

Installation size

No files were installed.

Uninstall

Command
opam remove -y coq-min-imports.1.0.1
Return code
0
Missing removes
none
Wrong removes
none