« Up

mtac 1.3.0 Not compatible

(2019-07-18 16:04:30 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
conf-m4             1                 Virtual package relying on m4
coq                 8.8.2             Formal proof management system.
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
ocamlfind           1.8.0             A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "gmalecha@gmail.com"
homepage: "https://github.com/beta-ziliani/mtac-plugin"
dev-repo: "git+https://github.com/beta-ziliani/mtac-plugin.git"
bug-reports: "https://github.com/beta-ziliani/mtac-plugin/issues"
authors: ["Beta Ziliani"]
license: "MIT"
build: [
  ["./configure.sh"]
  [make "-j%{jobs}%"]
]
install: [
  [make "install"]
]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/Mtac"]
depends: [
  "ocaml"
  "coq" {>= "8.5" & < "8.6"}
]
synopsis: "Typed Tactics for Coq 8.5"
flags: light-uninstall
url {
  src: "https://github.com/beta-ziliani/mtac-plugin/archive/v1.3.0.tar.gz"
  checksum: "md5=3e5b17dca8c533fee2a08bf6ab437f1b"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-mtac.1.3.0 coq.8.8.2
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.8.2).
The following dependencies couldn't be met:
  - coq-mtac -> coq < 8.6 -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-mtac.1.3.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none