« Up

coq-in-coq 8.5.0 Not compatible

(2019-07-12 08:57:54 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
conf-m4             1                 Virtual package relying on m4
coq                 8.9.0             Formal proof management system
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
ocamlfind           1.8.0             A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "matej.kosik@inria.fr"
homepage: "https://github.com/coq-contribs/coq-in-coq"
license: "LGPL 2"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/CoqInCoq"]
depends: [
  "ocaml"
  "coq" {>= "8.5" & < "8.6~"}
]
tags: [ "keyword:calculus of constructions" "category:Mathematics/Logic/Type theory" "category:Miscellaneous/Extracted Programs/Type checking unification and normalization" ]
authors: [ "Bruno Barras <>" ]
bug-reports: "https://github.com/coq-contribs/coq-in-coq/issues"
dev-repo: "git+https://github.com/coq-contribs/coq-in-coq.git"
synopsis: "A formalisation of the Calculus of Construction"
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/coq-in-coq/archive/v8.5.0.tar.gz"
  checksum: "md5=8fbdb233e6757c4a1057ae45efbced3d"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-coq-in-coq.8.5.0 coq.8.9.0
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.9.0).
The following dependencies couldn't be met:
  - coq-coq-in-coq -> coq < 8.6~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-coq-in-coq.8.5.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none