« Up

ott 0.28 Not compatible

(2019-07-12 08:57:54 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
conf-m4             1                 Virtual package relying on m4
coq                 8.9.0             Formal proof management system
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
ocamlfind           1.8.0             A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "palmskog@gmail.com"
authors: [ "Peter Sewell" "Francesco Zappa Nardelli" "Scott Owens" ]
homepage: "http://www.cl.cam.ac.uk/~pes20/ott/"
dev-repo: "git+https://github.com/ott-lang/ott.git"
bug-reports: "https://github.com/ott-lang/ott/issues"
license: "part BSD3, part LGPL 2.1"
build: [ make "-j%{jobs}%" "-C" "coq" ]
install: [ make "-C" "coq" "install" ]
remove: [ "sh" "-c" "rm -rf '%{lib}%/coq/user-contrib/Ott'" ]
depends: [
  "ocaml"
  "coq"
    {(>= "8.5" & < "8.6~") | (>= "8.6" & < "8.7~") | (>= "8.7" & < "8.8~") |
     (>= "8.8" & < "8.9~")}
]
tags: [
  "category:Computer Science/Semantics and Compilation/Semantics"
  "keyword:abstract syntax"
  "date:2018-04-24"
]
synopsis:
  "Auxiliary library for Ott, a tool for writing definitions of programming languages and calculi"
url {
  src: "https://github.com/ott-lang/ott/archive/0.28.tar.gz"
  checksum: "md5=42c76a821b8ba1528f6b99025cc6f2b0"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-ott.0.28 coq.8.9.0
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.9.0).
The following dependencies couldn't be met:
  - coq-ott -> coq < 8.6~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-ott.0.28
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none