« Up

squiggle-eq 1.0.2 Not compatible

(2019-07-12 08:57:54 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
conf-m4             1                 Virtual package relying on m4
coq                 8.9.0             Formal proof management system
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
ocamlfind           1.8.0             A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "abhishek.anand.iitg@gmail.com"
homepage: "https://github.com/aa755/SquiggleEq"
dev-repo: "git+https://github.com/aa755/SquiggleEq"
authors: ["Abhishek Anand" "Vincent Rahli"]
bug-reports: "https://github.com/aa755/SquiggleEq/issues"
license: "MIT"
build: [
  [make "-j%{jobs}%"]
]
install: [
  [make "install"]
]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/SquiggleEq"]
depends: [
  "ocaml"
  "coq" {>= "8.6" & < "8.7~"}
  "coq-ext-lib"
]
synopsis:
  "An abstract formalization of variable bindings (both named and de-bruijn),"
description: """
based on ideas in the following paper:
Howe, Douglas J. “Equality in Lazy Computation Systems.” In LICS, 198–203, 1989."""
flags: light-uninstall
url {
  src: "https://github.com/aa755/SquiggleEq/archive/1.0.2.tar.gz"
  checksum: "md5=0d072f3a98ceb9114f95837c450573d3"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-squiggle-eq.1.0.2 coq.8.9.0
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.9.0).
The following dependencies couldn't be met:
  - coq-squiggle-eq -> coq < 8.7~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-squiggle-eq.1.0.2
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none