« Up

cfgv 8.7.0 Not compatible

(2019-07-17 19:23:02 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
conf-m4             1                 Virtual package relying on m4
coq                 8.9.1             Formal proof management system
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
ocamlfind           1.8.0             A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "Hugo.Herbelin@inria.fr"
homepage: "https://github.com/coq-contribs/cfgv"
license: "LGPL"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/CFGV"]
depends: [
  "ocaml"
  "coq" {>= "8.7" & < "8.8~"}
]
tags: [ "keyword: generic programming" "keyword: variable bindings" "keyword: context free grammars" "keyword: substitution" "keyword: alpha equality" "keyword: equivariance" "category: Computer Science/Lambda Calculi" ]
authors: [ "Abhishek <abhishek.anand.iitg@gmail.com> [http://www.cs.cornell.edu/~aa755/]" "Vincent Rahli <vincent.rahli@gmail.com> [http://www.cs.cornell.edu/~rahli/]" ]
bug-reports: "https://github.com/coq-contribs/cfgv/issues"
dev-repo: "git+https://github.com/coq-contribs/cfgv.git"
synopsis: "Generic Proofs about Alpha Equality and Substitution"
description: """
http://www.nuprl.org/html/CFGVLFMTP2014/
Please read the following paper"""
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/cfgv/archive/v8.7.0.tar.gz"
  checksum: "md5=59a29ea2c3114e007451171d9de147d8"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-cfgv.8.7.0 coq.8.9.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.9.1).
The following dependencies couldn't be met:
  - coq-cfgv -> coq < 8.8~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-cfgv.8.7.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none