« Up

color 1.0.0 Not compatible

(2019-09-12 19:59:25 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-m4             1           Virtual package relying on m4
coq                 8.9.1       Formal proof management system
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "frederic.blanqui@inria.fr"
homepage: "http://color.inria.fr/"
license: "CeCILL"
build: [
  [make "-j%{jobs}%"]
]
install: [make "install"]
depends: [
  "ocaml"
  "coq" {>= "8.4pl2" & < "8.5~"}
]
authors: [
  "Frédéric Blanqui"
  "Adam Koprowski"
  "Sébastien Hinderer"
  "Pierre-Yves Strub"
  "Sidi Ould Biha"
  "Solange Coupet-Grimal"
  "William Delobel"
  "Hans Zantema"
  "Stéphane Leroux"
  "Léo Ducas"
  "Johannes Waldmann"
  "Qiand Wang"
  "Lianyi Zhang"
  "Sorin Stratulat"
]
synopsis: "A library on rewriting theory and termination"
url {
  src:
    "https://gforge.inria.fr/frs/download.php/file/35472/color.1.0.0.tar.gz"
  checksum: "md5=5277b9cfe0cb609f32dd5deb7795fb45"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-color.1.0.0 coq.8.9.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.9.1).
The following dependencies couldn't be met:
  - coq-color -> coq < 8.5~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-color.1.0.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none