« Up

extensible-records 1.1.0 Not compatible

(2019-09-12 19:59:25 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-m4             1           Virtual package relying on m4
coq                 8.9.1       Formal proof management system
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "gmalecha@gmail.com"
homepage: "https://github.com/gmalecha/coq-extensible-records"
dev-repo: "git+https://github.com/gmalecha/coq-extensible-records.git"
bug-reports: "https://github.com/gmalecha/coq-extensible-records/issues"
authors: ["Gregory Malecha"]
license: "MIT"
build: [
  [make "-j%{jobs}%"]
]
install: [
  [make "install"]
]
depends: [
  "ocaml"
  "coq" {>= "8.5.0" & < "8.9"}
]
synopsis: "Definitional (canonical) extensible records in Coq with string keys and arbitrary (non-dependent) types"
url {
  src:
    "https://github.com/gmalecha/coq-extensible-records/archive/v1.1.0.tar.gz"
  checksum: "md5=d2811c4ab38cbd7fa6785bd7d286b9d3"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-extensible-records.1.1.0 coq.8.9.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.9.1).
The following dependencies couldn't be met:
  - coq-extensible-records -> coq < 8.9 -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-extensible-records.1.1.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none