« Up

fsets 8.6.0 Not compatible

(2019-07-17 19:23:02 UTC)

Context

# Packages matching: installed
# Name              # Installed       # Synopsis
base-bigarray       base
base-num            base              Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.06.10-g84ce6cc4 Preprocessor-pretty-printer of OCaml
conf-m4             1                 Virtual package relying on m4
coq                 8.9.1             Formal proof management system
num                 0                 The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0            The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0            Official 4.05.0 release
ocaml-config        1                 OCaml Switch Configuration
ocamlfind           1.8.0             A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "Hugo.Herbelin@inria.fr"
homepage: "https://github.com/coq-contribs/fsets"
license: "LGPL 2.1"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/FSets"]
depends: [
  "ocaml"
  "coq" {>= "8.6" & < "8.7~"}
]
tags: [ "keyword: Finite Sets" "keyword: Sorted lists" "keyword: Balanced trees" "keyword: Red-black trees" "keyword: AVL" "keyword: Functors" "keyword: data structures" "category: Computer Science/Data Types and Data Structures" "category: Miscellaneous/Extracted Programs/Data structures" ]
authors: [ "Pierre Letouzey" "Jean-Christophe Filliâtre" ]
bug-reports: "https://github.com/coq-contribs/fsets/issues"
dev-repo: "git+https://github.com/coq-contribs/fsets.git"
synopsis: "Finite Sets overs Ordered Types"
description: """
This contribution contains several implementations of finite sets over
arbitrary ordered types using functors. Currently, there are 3
implementations: sorted lists, red-black trees and AVLs."""
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/fsets/archive/v8.6.0.tar.gz"
  checksum: "md5=535cd10d73dd4e4092058799de3c00a6"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-fsets.8.6.0 coq.8.9.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.9.1).
The following dependencies couldn't be met:
  - coq-fsets -> coq < 8.7~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-fsets.8.6.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none