« Up

lemma-overloading 8.8.0 Not compatible

(2019-11-05 05:47:05 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-findutils      1           Virtual package relying on findutils
conf-m4             1           Virtual package relying on m4
coq                 8.9.1       Formal proof management system
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "palmskog@gmail.com"
homepage: "https://github.com/coq-community/lemma-overloading"
dev-repo: "git+https://github.com/coq-community/lemma-overloading.git"
bug-reports: "https://github.com/coq-community/lemma-overloading/issues"
license: "GPL 3"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/LemmaOverloading"]
depends: [
  "ocaml"
  "coq" {>= "8.8" & < "8.9~"}
  "coq-mathcomp-ssreflect" {>= "1.6.2" & < "1.8~"}
]
tags: [
  "keyword:canonical structures"
  "keyword:proof automation"
  "keyword:hoare type theory"
  "keyword:lemma overloading"
  "category:Computer Science/Data Types and Data Structures"
  "date:2018-07-24"
  "logpath:LemmaOverloading"
]
authors: [
  "Georges Gonthier"
  "Beta Ziliani"
  "Aleksandar Nanevski"
  "Derek Dreyer"
]
synopsis:
  "Hoare Type Theory libraries showcasing design patterns for programming with canonical structures"
flags: light-uninstall
url {
  src:
    "https://github.com/coq-community/lemma-overloading/archive/v8.8.0.tar.gz"
  checksum: "md5=a7056f6477fc274d2c0ef30dab492bde"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-lemma-overloading.8.8.0 coq.8.9.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.9.1).
The following dependencies couldn't be met:
  - coq-lemma-overloading -> coq < 8.9~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-lemma-overloading.8.8.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none