« Up

mirror-core 1.0.1 Not compatible

(2019-10-06 16:15:31 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-m4             1           Virtual package relying on m4
coq                 8.9.1       Formal proof management system
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "gmalecha@gmail.com"
homepage: "https://github.com/gmalecha/mirror-core"
dev-repo: "git+https://github.com/gmalecha/mirror-core.git"
bug-reports: "https://github.com/gmalecha/mirror-core/issues"
authors: ["Gregory Malecha"]
license: "BSD"
build: [
  [make "-j%{jobs}%"]
]
install: [
  [make "install"]
]
remove: [
  ["rm" "-R" "%{lib}%/coq/user-contrib/MirrorCore"]
  ["rm" "-R" "%{lib}%/coq/user-contrib/McExamples"]
]
depends: [
  "ocaml"
  "coq" {>= "8.5.0" & < "8.5.2~"}
  "coq-ext-lib" {>= "0.9.2"}
  "coq-plugin-utils"
]
synopsis: "A framework for computational reflection"
flags: light-uninstall
url {
  src: "https://github.com/gmalecha/mirror-core/archive/v1.0.1.tar.gz"
  checksum: "md5=3c61f6c8134ec6b5d3ea0af826d5156f"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-mirror-core.1.0.1 coq.8.9.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.9.1).
The following dependencies couldn't be met:
  - coq-mirror-core -> coq < 8.5.2~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-mirror-core.1.0.1
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none