« Up

rational 8.5.0 Not compatible

(2019-11-05 05:47:05 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
camlp5              7.10        Preprocessor-pretty-printer of OCaml
conf-findutils      1           Virtual package relying on findutils
conf-m4             1           Virtual package relying on m4
coq                 8.9.1       Formal proof management system
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "matej.kosik@inria.fr"
homepage: "https://github.com/coq-contribs/rational"
license: "LGPL 2"
build: [make]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/Rational"]
depends: [
  "ocaml"
  "coq" {>= "8.5" & < "8.6~"}
]
tags: [ "keyword:integers" "keyword:rational numbers" "keyword:quotient types" "keyword:subset types" "category:Mathematics/Arithmetic and Number Theory/Rational numbers" ]
authors: [ "Samuel Boutin <>" ]
bug-reports: "https://github.com/coq-contribs/rational/issues"
dev-repo: "git+https://github.com/coq-contribs/rational.git"
synopsis: "A definition of rational numbers"
description: """
Definition of integers as the usual symetric
completion of a semi-group and of rational numbers as the product of
integers and strictly positive integers quotiented by the usual relation.
This implementation assumes two sets of axioms allowing to define
quotient types and subset types. These sets of axioms should be
proved coherent by mixing up the deliverable model and the setoid model
(both are presented in Martin Hofmann' thesis)."""
flags: light-uninstall
url {
  src: "https://github.com/coq-contribs/rational/archive/v8.5.0.tar.gz"
  checksum: "md5=acdf188400f2078d4210f6547b738bd1"
}

Lint

Command
true
Return code
0

Dry install

Dry install with the current Coq version:

Command
opam install -y --show-action coq-rational.8.5.0 coq.8.9.1
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.9.1).
The following dependencies couldn't be met:
  - coq-rational -> coq < 8.6~ -> ocaml < 4.03.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-rational.8.5.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall

Command
true
Return code
0
Missing removes
none
Wrong removes
none