ยซ Up

coqide 8.5~beta3 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2019-11-29 00:21:18 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-m4             1           Virtual package relying on m4
coq                 8.11.dev    Formal proof management system
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "coqdev@inria.fr"
homepage: "https://coq.inria.fr/"
license: "LGPL-2.1"
build: [
  ["./configure" "-configdir" "%{lib}%/coq/config" "-mandir" man "-docdir" doc "-prefix" prefix "-usecamlp5" "-camlp5dir" "%{lib}%/camlp5"]
  [make "-j%{jobs}%" "coqide-files"]
  [make "-j%{jobs}%" "coqide-binaries"]
  [make "install-ide-bin" "install-ide-files" "install-ide-info" "install-ide-devfiles"]
]
remove: ["rm" "-R" "%{lib}%/coq/ide" "%{doc}%/FAQ-CoqIde"]
depends: [
  "ocaml"
  "camlp5"
  "coq" {= "8.5~beta3"}
  "lablgtk"
  "conf-gtksourceview"
]
synopsis: "IDE of the Coq formal proof management system."
flags: light-uninstall
extra-files: ["coq-coqide.install" "md5=d005cda8cb7888fbea94c5416dcb31bc"]
url {
  src: "https://github.com/coq/coq/archive/V8.5beta3.tar.gz"
  checksum: "md5=5d4b60f163d87e20b8f26cacb61d9d3d"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-coqide.8.5~beta3 coq.8.11.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.11.dev).
The following dependencies couldn't be met:
  - coq-coqide -> coq = 8.5~beta3 -> ocaml < 4.05.0
      base of this switch (use `--unlock-base' to force)
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-coqide.8.5~beta3
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none