ยซ Up

geocoq 2.4.0 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2019-11-29 00:21:18 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-m4             1           Virtual package relying on m4
coq                 8.11.dev    Formal proof management system
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
synopsis: "A formalization of foundations of geometry in Coq"
description: "This package depends on all subpackages."
maintainer: "Julien Narboux <julien@narboux.fr>"
authors: ["Michael Beeson <profbeeson@gmail.com>"
          "Gabriel Braun <gabriel.braun@unistra.fr>"
          "Pierre Boutry <pierre.boutry@inria.fr>"
          "Cyril Cohen <cyril.cohen@inria.fr>"
          "Charly Gries <charly.gries@etu.unistra.fr>"
          "Julien Narboux <narboux@unistra.fr>"
          "Pascal Schreck <schreck@unistra.fr>"
          "Freek Wiedijk <freek@cs.ru.nl>"]
license: "LGPL 3"
homepage: "http://geocoq.github.io/GeoCoq/"
bug-reports: "https://github.com/GeoCoq/GeoCoq/issues"
dev-repo: "git+https://github.com/GeoCoq/GeoCoq.git"
depends: [
  "coq-geocoq-elements" { = "2.4.0" }
  "coq-geocoq-pof" { = "2.4.0" }
]
tags: [ "keyword:geometry"
        "keyword:neutral geometry"
        "keyword:euclidean geometry"
        "keyword:foundations"
        "keyword:Tarski"
        "keyword:Hilbert"
        "keyword:Euclid"
        "keyword:Elements"
        "keyword:Pappus"
        "keyword:Desargues"
        "keyword:arithmetization"
        "keyword:Pythagoras"
        "keyword:Thales' intercept theorem"
        "keyword:continuity"
        "keyword:ruler and compass"
        "keyword:parallel postulates"
        "keyword:model"
        "keyword:Cartesian space"
        "keyword:automation"
        "category:Mathematics/Geometry/General"
        "date:2018-06-13" ]
url {
  src: "https://github.com/GeoCoq/GeoCoq/archive/v2.4.0.tar.gz"
  checksum: "md5=4a4ad33b4cad9b815a9b5c6308524c63"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-geocoq.2.4.0 coq.8.11.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.11.dev).
The following dependencies couldn't be met:
  - coq-geocoq -> coq-geocoq-elements -> coq-geocoq-axioms -> coq-geocoq-coinc -> coq < 8.10~ -> ocaml < 4.05.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-geocoq.2.4.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none