ยซ Up

libhyps 1.0.0 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2019-11-29 00:21:18 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-m4             1           Virtual package relying on m4
coq                 8.11.dev    Formal proof management system
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
name: "coq-libhyps"
version: "1.0.0"
maintainer: "Pierre.Courtieu@lecnam.net"
synopsis: "Hypotheses manipulation library"
homepage: "https://github.com/Matafou/LibHyps"
dev-repo: "git+https://github.com/Matafou/LibHyps.git"
bug-reports: "https://github.com/Matafou/LibHyps/issues"
doc: "https://github.com/Matafou/LibHyps"
license: "GPL3"
build: [
  ["./configure.sh"]
  [make "-j%{jobs}%"]
]
install: [make "install"]
depends: [
  "coq" {(>= "8.9" & < "8.10~") | (= "dev")}
]
tags: [
  "keyword:proof environment manipulation"
  "keyword:forward reasoning"
  "keyword:hypothesis naming"
]
authors: [
 "Pierre Courtieu"
]
description: "
This library defines a set of tactics to manipulate hypothesis
indivually or by group. In particular it allows to apply a tactic on
each hypothesis of a goal, or only *new* hypothesis after some tactic.
Manipulations include: automatic renaming, decomposition, extracting
premisses, but define your own manipulation on (groups of) hypothesis.
"
url {
    http: "https://github.com/Matafou/LibHyps/archive/libhyps-1.0.0.tar.gz"
    checksum: "07830a474ce69f1040677141880995c2"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-libhyps.1.0.0 coq.8.11.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.11.dev).
The following dependencies couldn't be met:
  - coq-libhyps -> coq (< 8.10~ & = dev) -> ocaml < 4.05.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-libhyps.1.0.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none