ยซ Up

menhirlib 20180530 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2019-11-29 00:21:18 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-m4             1           Virtual package relying on m4
coq                 8.11.dev    Formal proof management system
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
synopsis: "A support library for verified Coq parsers produced by Menhir"
maintainer: "francois.pottier@inria.fr"
authors: "Jacques-Henri Jourdan <jacques-henri.jourdan@lri.fr>"
license: "GPL 2 & INRIA Non-Commercial License Agreement"
homepage: "https://gitlab.inria.fr/fpottier/coq-menhirlib"
bug-reports: "jacques-henri.jourdan@lri.fr"
dev-repo: "git+https://gitlab.inria.fr/fpottier/coq-menhirlib.git"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: [make "uninstall"]
depends: [
  "ocaml"
  "coq" {(>= "8.6" & <= "8.8.1")}
]
depopts: "menhir"
conflicts: [
  "menhir" {< "20180530"}
]
url {
  src:
    "https://gitlab.inria.fr/fpottier/coq-menhirlib/repository/20180530/archive.tar.gz"
  checksum: "md5=1c88edd2a6650c270ebd46247179363c"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-menhirlib.20180530 coq.8.11.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.11.dev).
The following dependencies couldn't be met:
  - coq-menhirlib -> coq < 8.8.2 -> ocaml < 4.05.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-menhirlib.20180530
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none