ยซ Up

reflexive-first-order 8.8.0 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2019-11-29 00:21:18 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-m4             1           Virtual package relying on m4
coq                 8.11.dev    Formal proof management system
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "Hugo.Herbelin@inria.fr"
homepage: "https://github.com/coq-contribs/reflexive-first-order"
license: "LGPL"
build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-R" "%{lib}%/coq/user-contrib/ReflexiveFirstOrder"]
depends: [
  "ocaml"
  "coq" {>= "8.8" & < "8.9~"}
]
tags: [ "keyword: computationnal reflection" "keyword: interpretation" "keyword: first-order logic" "keyword: equational reasoning" "category: Miscellaneous/Coq Extensions" "date: 2005-05" ]
authors: [ "Pierre Corbineau <pierre.corbineau@lri.fr> [http://www.cs.ru.nl/~corbineau]" ]
bug-reports: "https://github.com/coq-contribs/reflexive-first-order/issues"
dev-repo: "git+https://github.com/coq-contribs/reflexive-first-order.git"
synopsis: "Reflexive first-order proof interpreter"
description: """
This contribution is a package which can be used to interpret firstorder
proofs provided by an external theorem prover, using computationnal
reflexion."""
flags: light-uninstall
url {
  src:
    "https://github.com/coq-contribs/reflexive-first-order/archive/v8.8.0.tar.gz"
  checksum: "md5=1d9a59f1bcae100117c45eefd670e30b"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-reflexive-first-order.8.8.0 coq.8.11.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.11.dev).
The following dependencies couldn't be met:
  - coq-reflexive-first-order -> coq < 8.9~ -> ocaml < 4.05.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-reflexive-first-order.8.8.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none