ยซ Up

typing-flags 1.0 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2019-11-29 00:21:18 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-num            base        Num library distributed with the OCaml compiler
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-m4             1           Virtual package relying on m4
coq                 8.11.dev    Formal proof management system
num                 0           The Num library for arbitrary-precision integer and rational arithmetic
ocaml               4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler 4.05.0      Official 4.05.0 release
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.8.1       A library manager for OCaml
# opam file:
opam-version: "2.0"
maintainer: "dev@clarus.me"
homepage: "https://github.com/SimonBoulier/TypingFlags"
dev-repo: "git+https://github.com/SimonBoulier/TypingFlags.git"
bug-reports: "https://github.com/SimonBoulier/TypingFlags/issues"
authors: ["Simon Boulier"]
license: "Unknown"
build: [
  [make "-j%{jobs}%"]
]
install: [
  [make "install"]
]
depends: [
  "coq" {>= "8.7" & < "8.10~"}
  "ocaml"
]
tags: [
  "keyword:non-termination"
  "keyword:type-in-type"
  "category:Misc/Coq Extensions"
  "date:2019-11-02"
  "logpath:TypingFlags"
]
synopsis: "A Coq plugin to disable positivity check, guard check and termination check"
url {
  src: "https://github.com/SimonBoulier/TypingFlags/archive/v1.0.tar.gz"
  checksum: "sha512=272748e6c0d505e4cc41d641e44f9088ab93c9412fe632b8ad67e0d223c234ba76059679674b6d170485ff3d24e1c6d35918a6a5c7336815e4ab32f43f581117"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-typing-flags.1.0 coq.8.11.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is 8.11.dev).
The following dependencies couldn't be met:
  - coq-typing-flags -> coq < 8.10~ -> ocaml < 4.05.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-typing-flags.1.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none