ยซ Up

concurrency-proxy 1.0.0 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2021-12-16 03:29:46 UTC)

Context

# Packages matching: installed
# Name                   # Installed # Synopsis
base-bigarray            base
base-threads             base
base-unix                base
conf-findutils           1           Virtual package relying on findutils
conf-gmp                 3           Virtual package relying on a GMP lib system installation
coq                      dev         Formal proof management system
dune                     2.9.1       Fast, portable, and opinionated build system
ocaml                    4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler      4.05.0      Official 4.05.0 release
ocaml-config             1           OCaml Switch Configuration
ocaml-secondary-compiler 4.08.1-1    OCaml 4.08.1 Secondary Switch Compiler
ocamlfind                1.9.1       A library manager for OCaml
ocamlfind-secondary      1.9.1       Adds support for ocaml-secondary-compiler to ocamlfind
zarith                   1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
maintainer: "dev@clarus.me"
homepage: "https://github.com/coq-concurrency/proxy"
dev-repo: "git+https://github.com/coq-concurrency/proxy.git"
bug-reports: "https://github.com/coq-concurrency/proxy/issues"
authors: ["Guillaume Claret"]
license: "MIT"
build: [
  [make "-j%{jobs}%"]
]
depends: [
  "ocaml" {>= "4.02.0" & < "4.06"}
  "base-unix"
  "lwt" {>= "2.4.5" & < "5"}
  "num"
  "base64" {>= "1.0.0" & < "2"}
]
conflicts: [
  "ocaml-secondary-compiler"
]
tags: [
  "date:2015-01-28"
  "keyword:effects"
  "keyword:extraction"
]
synopsis: "A proxy to interface concurrent Coq programs with the operating system"
extra-files: [
  "coq-concurrency-proxy.install" "md5=96f86b964fc4cd99c310011b83de5f61"
]
url {
  src: "https://github.com/coq-concurrency/proxy/archive/1.0.0.tar.gz"
  checksum: "md5=36d201bf65ccc649b4704e71e94de712"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-concurrency-proxy.1.0.0 coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq -> dune >= 2.5.1 -> ocamlfind-secondary -> ocaml-secondary-compiler
Your request can't be satisfied:
  - coq-concurrency-proxy is in conflict with ocaml-secondary-compiler
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-concurrency-proxy.1.0.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none