ยซ Up

io-hello-world 1.2.0 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2021-12-16 03:29:46 UTC)

Context

# Packages matching: installed
# Name                   # Installed # Synopsis
base-bigarray            base
base-threads             base
base-unix                base
conf-findutils           1           Virtual package relying on findutils
conf-gmp                 3           Virtual package relying on a GMP lib system installation
coq                      dev         Formal proof management system
dune                     2.9.1       Fast, portable, and opinionated build system
ocaml                    4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler      4.05.0      Official 4.05.0 release
ocaml-config             1           OCaml Switch Configuration
ocaml-secondary-compiler 4.08.1-1    OCaml 4.08.1 Secondary Switch Compiler
ocamlfind                1.9.1       A library manager for OCaml
ocamlfind-secondary      1.9.1       Adds support for ocaml-secondary-compiler to ocamlfind
zarith                   1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
maintainer: "dev@clarus.me"
homepage: "https://github.com/clarus/coq-hello-world"
dev-repo: "git+https://github.com/clarus/coq-hello-world.git"
bug-reports: "https://github.com/clarus/coq-hello-world/issues"
authors: ["Guillaume Claret"]
license: "MIT"
build: [
  ["./configure.sh"]
  [make "-j%{jobs}%"]
  [make "-C" "extraction"]
]
install: [
  ["install" "-T" "extraction/main.native" "%{bin}%/helloWorld"]
]
depends: [
  "coq" {build}
  "coq-io" {>= "4.0.0" & build}
  "coq-io-system" {build}
  "coq-io-system-ocaml" {>= "2.3.0"}
]
tags: [
  "date:2019-07-30"
  "keyword:effects"
  "keyword:extraction"
]
synopsis: "A Hello World program in Coq"
url {
  src: "https://github.com/coq-io/hello-world/archive/1.2.0.tar.gz"
  checksum: "sha512=00f1beee8dbb62b6b619d9942f6701ef557ce3de3568f324103c1073968a3f07b7d5fa797e9ca955ec7d7ac36db5e039ef29c5666bfa4a5fe755b03615dface1"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-io-hello-world.1.2.0 coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-io-hello-world -> coq-io >= 4.0.0
  - coq-io-hello-world -> coq-io-system -> coq-io-system-ocaml >= 2.3.0
  - coq-io-hello-world -> coq-io-system -> coq-io < 4
  - coq-io-hello-world -> coq-io-system -> coq < 8.5~ -> ocaml < 4.05.0
      base of this switch (use `--unlock-base' to force)
  - coq -> dune >= 2.5.1 -> ocamlfind-secondary -> ocaml-secondary-compiler
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
  - No available version of coq-io satisfies the constraints
  - coq-io-system-ocaml >= 2.3.0 is in conflict with ocaml-secondary-compiler
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-io-hello-world.1.2.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none