« Up

katamaran 0.1.0 Not compatible 👼

📅 (2021-12-16 03:29:46 UTC)

Context

# Packages matching: installed
# Name                   # Installed # Synopsis
base-bigarray            base
base-threads             base
base-unix                base
conf-findutils           1           Virtual package relying on findutils
conf-gmp                 3           Virtual package relying on a GMP lib system installation
coq                      dev         Formal proof management system
dune                     2.9.1       Fast, portable, and opinionated build system
ocaml                    4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler      4.05.0      Official 4.05.0 release
ocaml-config             1           OCaml Switch Configuration
ocaml-secondary-compiler 4.08.1-1    OCaml 4.08.1 Secondary Switch Compiler
ocamlfind                1.9.1       A library manager for OCaml
ocamlfind-secondary      1.9.1       Adds support for ocaml-secondary-compiler to ocamlfind
zarith                   1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
synopsis: "Separation logic-based verification of instruction sets"
description: """
Katamaran is a semi-automated separation logic verifier for
the Sail specification language. It works on an embedded
version of Sail called μSail and verifies separation
logic-based contracts of functions by generating (succinct)
first-order verification conditions. It further comes with a
complete model based on the Iris separation logic
framework."""
maintainer: ["Steven Keuchel <steven.keuchel@vub.be>"]
authors: [
  "Dominique Devriese"
  "Georgy Lukyanov"
  "Sander Huyghebaert"
  "Steven Keuchel"
]
license: "BSD-2-Clause"
tags: [
  "keyword:program verification"
  "keyword:separation logic"
  "keyword:symbolic execution"
  "keyword:instruction sets"
  "category:Computer Science/Semantics and Compilation/Semantics"
  "data:2021-10-15"
  "logpath:Katamaran"
]
homepage: "https://katamaran-project.github.io/"
bug-reports: "https://github.com/katamaran-project/katamaran/issues"
depends: [
  "dune"                  {>= "2.5"}
  "coq"                   {>= "8.12" & < "8.15"}
  "coq-bbv"               {>= "1.2"  & < "1.3"}
  "coq-equations"         {>= "1.2"  & < "1.4"}
  "coq-iris"              {>= "3.4"  & < "3.5"}
  "coq-stdpp"             {>= "1.5"  & < "1.6"}
]
build: [ "dune" "build" "-p" name "-j" jobs ]
dev-repo: "git+https://github.com/katamaran-project/katamaran.git"
url {
  src: "https://github.com/katamaran-project/katamaran/archive/v0.1.0.tar.gz"
  checksum: "sha256=cb3d1b9121cdff09367d04caf01b595affae4600a10e73d2890c07f4aee3cbbb"
}

Lint

Command
true
Return code
0

Dry install 🏜️

Dry install with the current Coq version:

Command
opam install -y --show-action coq-katamaran.0.1.0 coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-katamaran -> coq < 8.15 -> ocaml < 4.05.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-katamaran.0.1.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install 🚀

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall 🧹

Command
true
Return code
0
Missing removes
none
Wrong removes
none