« Up

matching-logic dev Not compatible 👼

📅 (2021-12-16 03:29:46 UTC)

Context

# Packages matching: installed
# Name                   # Installed # Synopsis
base-bigarray            base
base-threads             base
base-unix                base
conf-findutils           1           Virtual package relying on findutils
conf-gmp                 3           Virtual package relying on a GMP lib system installation
coq                      dev         Formal proof management system
dune                     2.9.1       Fast, portable, and opinionated build system
ocaml                    4.05.0      The OCaml compiler (virtual package)
ocaml-base-compiler      4.05.0      Official 4.05.0 release
ocaml-config             1           OCaml Switch Configuration
ocaml-secondary-compiler 4.08.1-1    OCaml 4.08.1 Secondary Switch Compiler
ocamlfind                1.9.1       A library manager for OCaml
ocamlfind-secondary      1.9.1       Adds support for ocaml-secondary-compiler to ocamlfind
zarith                   1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
maintainer: "jenda.tusil@gmail.com"
homepage: "https://github.com/harp-project/AML-Formalization"
dev-repo: "git+https://github.com/harp-project/AML-Formalization.git"
bug-reports: "https://github.com/harp-project/AML-Formalization/issues"
license: "LGPL-2.1-only"
synopsis: "Matching Logic in Coq"
description: """
A library for Matching Logic."""
build: ["dune" "build" "-p" name "-j" jobs]
depends: [
  "coq" {>= "8.12" & < "8.13~"}
  "dune" {>= "2.5"}
]
tags: [
  "category:Mathematics/Logic"
]
authors: [
  "Jan Tusil"
  "Lucas Peña"
  "Attila Boros"
  "Mizsei Tamás"
]
url {
  src: "git+https://github.com/harp-project/AML-Formalization.git#master"
}

Lint

Command
true
Return code
0

Dry install 🏜️

Dry install with the current Coq version:

Command
opam install -y --show-action coq-matching-logic.dev coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-matching-logic -> coq < 8.13~ -> ocaml < 4.05.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-matching-logic.dev
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install 🚀

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall 🧹

Command
true
Return code
0
Missing removes
none
Wrong removes
none