ยซ Up

dpdgraph 0.5 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2022-05-24 01:37:32 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-gmp            4           Virtual package relying on a GMP lib system installation
coq                 dev         Formal proof management system
dune                3.1.1       Fast, portable, and opinionated build system
ocaml               4.10.2      The OCaml compiler (virtual package)
ocaml-base-compiler 4.10.2      Official release 4.10.2
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.9.3       A library manager for OCaml
zarith              1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
maintainer: "yves.bertot@inria.fr"
license: "LGPL 2.1"
homepage: "https://github.com/karmaki/coq-dpdgraph"
build: [
  ["./configure"]
  ["echo" "%{jobs}%" "jobs for the linter"]
  [make]
]
install: [make "install" "BINDIR=%{bin}%"]
depends: [
  "ocaml"
  "coq" {>= "8.5" & < "8.6~"}
  "ocamlgraph"
]
authors: [ "Anne Pacalet" "Yves Bertot"]
tags: [
  "logpath:dpdgraph"
]
synopsis: "Compute dependencies between Coq objects (definitions, theorems) and produce graphs"
url {
  src:
    "https://github.com/ybertot/coq-dpdgraph/archive/coq-dpdgraph-0.5-rc2.zip"
  checksum: "md5=d9614264c394080c2734638befaf0483"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-dpdgraph.0.5 coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-dpdgraph -> coq < 8.6~ -> ocaml < 4.06.0
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-dpdgraph.0.5
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none