ยซ Up

infotheo 0.0.7 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2022-05-24 01:37:32 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-gmp            4           Virtual package relying on a GMP lib system installation
coq                 dev         Formal proof management system
dune                3.1.1       Fast, portable, and opinionated build system
ocaml               4.10.2      The OCaml compiler (virtual package)
ocaml-base-compiler 4.10.2      Official release 4.10.2
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.9.3       A library manager for OCaml
zarith              1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
maintainer: "reynald.affeldt@aist.go.jp"
homepage: "https://github.com/affeldt-aist/infotheo"
bug-reports: "https://github.com/affeldt-aist/infotheo/issues"
dev-repo: "git+https://github.com/affeldt-aist/infotheo.git"
license: "GPL-3.0-or-later"
authors: [
  "Reynald Affeldt"
  "Manabu Hagiwara"
  "Jonas Senizergues"
  "Jacques Garrigue"
  "Kazuhiko Sakaguchi"
  "Taku Asai"
  "Takafumi Saikawa"
  "Naruomi Obata"
  "Erik Martin-Dorel"
  "Ryosuke Obi"
  "Mitsuharu Yamamoto"
]
build: [
  [make "-j%{jobs}%"]
  [make "-C" "extraction" "tests"] {with-test}
]
install: [
  [make "install"]
]
depends: [
  "coq" {>= "8.10~"}
  "coq-mathcomp-field" {>= "1.10.0"}
  "coq-mathcomp-analysis"   {(>= "0.2.0" & <= "0.2.3")}
]
synopsis: "Infotheo"
description: """
a Coq formalization of information theory and linear error-correcting codes
"""
tags: [
  "category:Computer Science/Data Types and Data Structures"
  "keyword: information theory"
  "keyword: probability"
  "keyword: error-correcting codes"
  "logpath:infotheo"
  "date:2020-02-06"
]
url {
  http: "https://github.com/affeldt-aist/infotheo/archive/0.0.7.tar.gz"
  checksum: "sha512=8cf6f3580a3afd3bb02197f643adb4ea24237e0ee65f1499d32ac15c3cdc775a5e093f833381ddf59f9de4bc08f032960d71e139281ac504093ec547796424e9"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-infotheo.0.0.7 coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-infotheo -> coq-mathcomp-analysis < 0.3.0 -> coq-mathcomp-finmap < 1.5.0 -> coq < 8.12~ -> ocaml < 4.10
      base of this switch (use `--unlock-base' to force)
  - coq-infotheo -> coq-mathcomp-analysis < 0.3.0 -> coq-mathcomp-finmap < 1.5.0 -> coq-mathcomp-ssreflect < 1.8~ -> coq < 8.10~ -> ocaml < 4.10
      base of this switch (use `--unlock-base' to force)
  - coq-infotheo -> coq-mathcomp-analysis < 0.3.0 -> coq < 8.9~ -> ocaml < 4.10
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-infotheo.0.0.7
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none