ยซ Up

io 4.0.0 Error ๐Ÿ”ฅ

๐Ÿ“… (2022-05-24 01:37:32 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-gmp            4           Virtual package relying on a GMP lib system installation
coq                 dev         Formal proof management system
dune                3.1.1       Fast, portable, and opinionated build system
ocaml               4.10.2      The OCaml compiler (virtual package)
ocaml-base-compiler 4.10.2      Official release 4.10.2
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.9.3       A library manager for OCaml
zarith              1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
maintainer: "dev@clarus.me"
homepage: "https://github.com/clarus/io"
dev-repo: "git+https://github.com/clarus/io.git"
bug-reports: "https://github.com/clarus/io/issues"
authors: ["Guillaume Claret"]
license: "MIT"
build: [
  ["./configure.sh"]
  [make "-j%{jobs}%"]
]
install: [
  [make "install"]
]
depends: [
  "ocaml"
  "coq" {>= "8.5"}
]
synopsis: "A library for effects in Coq"
tags: [
  "date:2019-07-23"
  "logpath:Io"
  "keyword:effects"
]
url {
  src: "https://github.com/coq-io/io/archive/4.0.0.tar.gz"
  checksum: "sha512=4530f51f704c09d62870ab68f88705c18cc3a1923ee23382b8c2777b2dcb07b73f0a0a14f80f9b99708c9457065608082b1ebf3b243e2c6cb9c521173e5f2695"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-io.4.0.0 coq.dev
Return code
0

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
true
Return code
0

Install dependencies

Command
opam list; echo; ulimit -Sv 4000000; timeout 4h opam install -y --deps-only coq-io.4.0.0 coq.dev
Return code
0
Duration
12 s

Install ๐Ÿš€

Command
opam list; echo; ulimit -Sv 16000000; timeout 4h opam install -y -v coq-io.4.0.0 coq.dev
Return code
7936
Duration
18 s
Output
# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-gmp            4           Virtual package relying on a GMP lib system installation
coq                 dev         Formal proof management system
dune                3.1.1       Fast, portable, and opinionated build system
ocaml               4.10.2      The OCaml compiler (virtual package)
ocaml-base-compiler 4.10.2      Official release 4.10.2
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.9.3       A library manager for OCaml
zarith              1.12        Implements arithmetic and logical operations over arbitrary-precision integers
[NOTE] Package coq is already installed (current version is dev).
The following actions will be performed:
  - install coq-io 4.0.0
<><> Gathering sources ><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/1: [coq-io.4.0.0: http]
[coq-io.4.0.0] downloaded from https://github.com/coq-io/io/archive/4.0.0.tar.gz
Processing  1/1:
<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/2: [coq-io: ./configure.sh]
+ /home/bench/.opam/opam-init/hooks/sandbox.sh "build" "./configure.sh" (CWD=/home/bench/.opam/ocaml-base-compiler.4.10.2/.opam-switch/build/coq-io.4.0.0)
Processing  1/2: [coq-io: make]
+ /home/bench/.opam/opam-init/hooks/sandbox.sh "build" "make" "-j4" (CWD=/home/bench/.opam/ocaml-base-compiler.4.10.2/.opam-switch/build/coq-io.4.0.0)
- COQDEP VFILES
- COQC src/Effect.v
- COQC src/C.v
- COQC src/Run.v
- COQC src/Evaluate.v
- COQC src/List.v
- COQC src/Trace.v
- COQC src/UseCase.v
- File "./src/List.v", line 42, characters 9-10:
- Error: Syntax error: [identref] expected after 'let!' (in [binder_constr]).
- 
- make[1]: *** [Makefile:791: src/List.vo] Error 1
- make[1]: *** Waiting for unfinished jobs....
- make: *** [Makefile:408: all] Error 2
[ERROR] The compilation of coq-io failed at "/home/bench/.opam/opam-init/hooks/sandbox.sh build make -j4".
#=== ERROR while compiling coq-io.4.0.0 =======================================#
# context              2.0.6 | linux/x86_64 | ocaml-base-compiler.4.10.2 | file:///home/bench/run/opam-coq-archive/released
# path                 ~/.opam/ocaml-base-compiler.4.10.2/.opam-switch/build/coq-io.4.0.0
# command              ~/.opam/opam-init/hooks/sandbox.sh build make -j4
# exit-code            2
# env-file             ~/.opam/log/coq-io-17493-2dea01.env
# output-file          ~/.opam/log/coq-io-17493-2dea01.out
### output ###
# [...]
# COQC src/C.v
# COQC src/Run.v
# COQC src/Evaluate.v
# COQC src/List.v
# COQC src/Trace.v
# COQC src/UseCase.v
# File "./src/List.v", line 42, characters 9-10:
# Error: Syntax error: [identref] expected after 'let!' (in [binder_constr]).
# 
# make[1]: *** [Makefile:791: src/List.vo] Error 1
# make[1]: *** Waiting for unfinished jobs....
# make: *** [Makefile:408: all] Error 2
<><> Error report <><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
+- The following actions failed
| - build coq-io 4.0.0
+- 
- No changes have been performed
# Run eval $(opam env) to update the current shell environment
'opam install -y -v coq-io.4.0.0 coq.dev' failed.

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none