ยซ Up

iris-string-ident 0.1.0 Not compatible ๐Ÿ‘ผ

๐Ÿ“… (2022-05-24 01:37:32 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-gmp            4           Virtual package relying on a GMP lib system installation
coq                 dev         Formal proof management system
dune                3.1.1       Fast, portable, and opinionated build system
ocaml               4.10.2      The OCaml compiler (virtual package)
ocaml-base-compiler 4.10.2      Official release 4.10.2
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.9.3       A library manager for OCaml
zarith              1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
maintainer: "Ralf Jung <jung@mpi-sws.org>"
authors: "Tej Chajed <tchajed@mit.edu>"
license: "BSD-3-Clause"
homepage: "https://gitlab.mpi-sws.org/iris/string-ident"
bug-reports: "https://gitlab.mpi-sws.org/iris/string-ident/issues"
dev-repo: "git+https://gitlab.mpi-sws.org/iris/string-ident.git"
synopsis: "Add support for Gallina names in intro patterns to the Iris Proof Mode"
description: """
This package implements string_to_ident in Ltac2, enabling support for Gallina names in Iris intro patterns (within strings).
"""
depends: [
  "coq" {>= "8.11" & < "8.14~"}
  "coq-iris" {(>= "3.3.0" & < "3.5.0")}
]
build: [make "-j%{jobs}%"]
install: [make "install"]
tags: [
  "category:Miscellaneous/Coq Extensions"
  "keyword:iris"
  "logpath:iris_string_ident"
]
url {
  src:
    "https://gitlab.mpi-sws.org/iris/string-ident/-/archive/v0.1.0/string-ident-v0.1.0.tar.gz"
  checksum:
    "sha512=af7b009914cb0f3d3cb336bed5968916a5b9cee527c6a60a558e5e0c1919f182112937762aad7419fd62fbb0e624fb886e3f5fc419da7563a717d6412289f974"
}

Lint

Command
true
Return code
0

Dry install ๐Ÿœ๏ธ

Dry install with the current Coq version:

Command
opam install -y --show-action coq-iris-string-ident.0.1.0 coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-iris-string-ident -> coq < 8.14~ -> ocaml < 4.10
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-iris-string-ident.0.1.0
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install ๐Ÿš€

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall ๐Ÿงน

Command
true
Return code
0
Missing removes
none
Wrong removes
none