« Up

itauto 8.13+no Not compatible 👼

📅 (2022-05-24 01:37:32 UTC)

Context

# Packages matching: installed
# Name              # Installed # Synopsis
base-bigarray       base
base-threads        base
base-unix           base
conf-findutils      1           Virtual package relying on findutils
conf-gmp            4           Virtual package relying on a GMP lib system installation
coq                 dev         Formal proof management system
dune                3.1.1       Fast, portable, and opinionated build system
ocaml               4.10.2      The OCaml compiler (virtual package)
ocaml-base-compiler 4.10.2      Official release 4.10.2
ocaml-config        1           OCaml Switch Configuration
ocamlfind           1.9.3       A library manager for OCaml
zarith              1.12        Implements arithmetic and logical operations over arbitrary-precision integers
# opam file:
opam-version: "2.0"
maintainer: "frederic.besson@inria.fr"
homepage: "https://gitlab.inria.fr/fbesson/itauto"
dev-repo: "git+https://gitlab.inria.fr/fbesson/itauto.git"
authors: ["Frédéric Besson"]
bug-reports: "frederic.besson@inria.fr"
license: "MIT"
synopsis: "'itauto' is a reflexive SAT solver parameterised by a leaf tactic and Nelson-Oppen support"
build: [
  [make]
]
install: [
  [make "install"]
]
depends: [
  "ocaml" {>= "4.9~" & < "4.13~"}
  "coq" {>= "8.13" & < "8.14"}
  "ocamlbuild" {build }
]
depopts: [ "ocamlformat" {build} ]
tags: [
  "keyword:integers" "keyword:SAT" "keyword:SMT" "keyword:Nelson-Oppen" "keyword:automation"
  "logpath:Cdcl"
]
url {
  src:
    "https://gitlab.inria.fr/fbesson/itauto/-/archive/8.13+no/itauto-8.13+no.tar.gz"
  checksum: [
    "md5=2d7d832b1c36a3726ea8e0995f50f156"
    "sha512=14574dcb3b98870b5ae37de93800493fc21c6ae1d44517bdcbbf4a5fda839f78968454e2ebdba19225b7db16ada0bdbaccf50c3ba8c890bbd94250c5e48c3719"
  ]
}

Lint

Command
true
Return code
0

Dry install 🏜️

Dry install with the current Coq version:

Command
opam install -y --show-action coq-itauto.8.13+no coq.dev
Return code
5120
Output
[NOTE] Package coq is already installed (current version is dev).
The following dependencies couldn't be met:
  - coq-itauto -> coq < 8.14 -> ocaml < 4.10
      base of this switch (use `--unlock-base' to force)
Your request can't be satisfied:
  - No available version of coq satisfies the constraints
No solution found, exiting

Dry install without Coq/switch base, to test if the problem was incompatibility with the current Coq/OCaml version:

Command
opam remove -y coq; opam install -y --show-action --unlock-base coq-itauto.8.13+no
Return code
0

Install dependencies

Command
true
Return code
0
Duration
0 s

Install 🚀

Command
true
Return code
0
Duration
0 s

Installation size

No files were installed.

Uninstall 🧹

Command
true
Return code
0
Missing removes
none
Wrong removes
none